We continue to investigate the underlying cause of the degraded reporting performance. At the same time, we are actively provisioning a new reporting fleet based on our enhanced scaling architecture as part of our mitigation efforts. We will share another update within 60 minutes.
Posted Aug 21, 2026 - 15:19 PDT
Update
We are still investigating reports of degraded performance and issues running reports. We will provide a further update within 60 minutes.
Posted Aug 21, 2026 - 14:20 PDT
Update
We are continuing to investigate reports of degraded performance and issues running reports. Our team remains actively engaged in identifying the root cause and will provide another update within 60 minutes.
Posted Aug 21, 2026 - 13:14 PDT
Investigating
We are investigating reports of degraded performance and difficulties running reports. Our team is actively working to identify the cause and will provide an update within 30 minutes.
Posted Aug 21, 2026 - 12:44 PDT
This incident affects: Aeries Cloud Services (AWS CA).