Increased Latency for Some Hosted Customers

Incident Report for Aeries Software

Resolved

This incident has been resolved.
Posted Aug 12, 2026 - 23:31 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 12, 2026 - 21:33 PDT

Identified

A configuration deployed in error created a performance issue. The change is being reverted.
Posted Aug 12, 2026 - 16:24 PDT

Investigating

We are currently investigating reports of increased latency and slower-than-normal performance affecting some Hosted customers. Our team has identified the source of the issue and is actively working to restore normal performance.
Posted Aug 12, 2026 - 12:21 PDT
This incident affected: Aeries Cloud Services (AWS CA).