Reports of latency, slowness, and timeouts for some customers

Incident Report for Aeries Software

Monitoring

Resource reallocation will occur tonight to address recent pressure
Posted Mar 06, 2026 - 16:01 PST

Investigating

We are currently investigating this issue.
Posted Mar 06, 2026 - 09:23 PST
This incident affects: Aeries Cloud Services (AWS CA).