Multiple districts are reporting slowness. Some customers are getting a timeout error.
Incident Report for Aeries Software
Resolved
The slowness issue has been mitigated and resolved. Thank you for your patience.
Posted May 31, 2023 - 09:52 PDT
Monitoring
We have identified and targeted areas for optimization. We are monitoring the issue.
Posted May 30, 2023 - 12:08 PDT
Identified
We have identified the problem causing slowness. Our database engineers are currently addressing the issue. An ETA is not available at this time. We will be in touch through this page with further updates.

Thank you for your patience.
Posted May 30, 2023 - 09:43 PDT
Investigating
We are currently investigating the issue. Please subscribe to this page to be notified when updates are available.

We apologize for the inconvenience.
Posted May 30, 2023 - 09:02 PDT
This incident affected: Aeries Cloud Services (AWS CA).