Aeries Web performance is degraded.
Incident Report for Aeries Software
Resolved
This incident has been resolved.
Posted Mar 09, 2020 - 10:54 PDT
Investigating
Some customers are experiencing degraded performance. We are currently investigating.
Posted Mar 09, 2020 - 10:08 PDT
This incident affected: Aeries Hosted Service.